Elevated error rate
Incident Report for Trustpilot
Resolved
This incident has been resolved.
Posted 6 months ago. Mar 01, 2019 - 13:03 CET
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 6 months ago. Mar 01, 2019 - 12:09 CET
This incident affected: General Availability (www.trustpilot.com).