Delay on signup and activation emails
Incident Report for Trustpilot
Resolved
All pending emails have been sent and services are operating as expected.
Posted 5 months ago. Mar 20, 2019 - 14:48 CET
Monitoring
Most queues are empty and processing as per normal
Posted 5 months ago. Mar 20, 2019 - 14:29 CET
Update
We are continuing to work on a fix for this issue.
Posted 5 months ago. Mar 20, 2019 - 14:28 CET
Identified
multiple email related systems have been experiencing delays since 10:20 UTC due to third party downtime - the issue is seemingly resolved and our systems are clearing their queues.
Posted 5 months ago. Mar 20, 2019 - 14:28 CET
This incident affected: General Availability (www.trustpilot.com).