we are experiencing a delay when processing invitations, but it should be solved in a few hours.
Incident Report for Trustpilot
Resolved
The incident is resolved.
Posted Sep 03, 2020 - 19:19 CEST
Investigating
We are currently investigating this issue.
Posted Sep 03, 2020 - 15:45 CEST