We're currently experiencing issues with scheduling invitations through our API method
Incident Report for Trustpilot
Resolved
This incident has been resolved.
Posted Mar 05, 2024 - 18:41 CET
Monitoring
The issues has been resolved and we are monitoring the affected services.
Posted Mar 05, 2024 - 14:05 CET
Investigating
We're currently working to resolve an issue that may temporarily affect scheduling invitations through our API method.
Posted Mar 05, 2024 - 13:46 CET
This incident affected: General Availability (APIs).