A fix has been implemented and we are monitoring the results.
Posted May 30, 2025 - 16:13 CEST
Identified
The issue has been identified and a fix is being implemented.
Posted May 30, 2025 - 15:53 CEST
Investigating
Some users are having trouble signing up for a free business account using the Google Sign-up option. Trustpilot is aware of the issue and working to resolve it urgently. We apologize for any inconvenience.
Posted May 30, 2025 - 15:51 CEST
This incident affected: General Availability (Business Portal).