High error rate on www.trustpilot.com
Incident Report for Trustpilot
Resolved
This incident has been resolved.
Posted 6 months ago. Jun 22, 2018 - 10:27 CEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 6 months ago. Jun 22, 2018 - 09:31 CEST
Identified
The issue has been identified and a fix is being implemented.
Posted 6 months ago. Jun 22, 2018 - 09:17 CEST
This incident affected: General Availability (www.trustpilot.com).