Delays sending review invitation emails using a custom template
Incident Report for Trustpilot
Resolved
The test invitation feature has been re-enabled and all platform features are fully operational.

We appreciate your patience.
Posted Sep 07, 2024 - 10:02 CEST
Update
The backlog of queued emails has been cleared, the test invitation feature remains disabled at this time. We appreciate your patience.
Posted Sep 07, 2024 - 09:08 CEST
Monitoring
We have implemented a partial fix and all emails are being successfully sent. Note that our test invitation feature will be disabled while our systems clear the backlog of queued emails to be sent. We appreciate your patience.
Posted Sep 06, 2024 - 12:45 CEST
Update
We are continuing to work on a fix for this issue. We appreciate your patience.
Posted Sep 06, 2024 - 09:00 CEST
Update
We are continuing to work on a fix for this issue.
Posted Sep 06, 2024 - 00:44 CEST
Update
We are continuing to work on a fix for this issue.
Posted Sep 05, 2024 - 21:01 CEST
Identified
The issue has been identified and a fix is being implemented.
Posted Sep 05, 2024 - 17:00 CEST
Update
We are continuing to investigate this issue.
Posted Sep 05, 2024 - 16:54 CEST
Investigating
We are currently Investigating a service disruption for the sending of review invitations using a custom template.
Posted Sep 05, 2024 - 16:50 CEST
This incident affected: invitation-reviews (custom template).