Reviews Not Loading
Incident Report for Trustpilot
Resolved
This incident has been resolved.
Posted Oct 30, 2023 - 13:05 CET
Monitoring
We've successfully deployed a fix, and we're actively monitoring the situation. We hope to mark this incident as resolved by 12:30 UTC.
Posted Oct 30, 2023 - 12:53 CET
Identified
We've identified a possible solution, and we are working to deploy a change soon. Further updates by 12:00 UTC.
Posted Oct 30, 2023 - 12:28 CET
Investigating
We are aware of an issue displaying reviews affecting both business customers and consumers. We're actively investigating and shall provide an update no later than 11:30 UTC
Posted Oct 30, 2023 - 12:08 CET