Service reviews delay on B2B app
Incident Report for Trustpilot
Resolved
This incident has been resolved.
Posted Jun 12, 2023 - 15:38 CEST
Investigating
We are currently experiencing issues regarding service reviews showing up with a considerable delay time on the B2B app.

At the time of writing, we are working on addressing the aforementioned as soon as we are able. We are sorry for any inconvenience.
Posted Jun 12, 2023 - 14:43 CEST
This incident affected: General Availability (Business Portal).