Issues reported around posting and editing reviews
Incident Report for Trustpilot
Resolved
This incident has been resolved.
Posted Dec 01, 2020 - 21:55 CET
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Dec 01, 2020 - 20:48 CET
Investigating
We're experiencing an increased number of errors on the review form.
Posted Dec 01, 2020 - 20:31 CET
This incident affected: General Availability (www.trustpilot.com).