High latency in company profile pages
Incident Report for Trustpilot
Resolved
This incident has been resolved.
Posted 4 months ago. Aug 13, 2018 - 22:12 CEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 4 months ago. Aug 13, 2018 - 18:42 CEST
Identified
The issue has been identified and a fix is being implemented.
Posted 4 months ago. Aug 13, 2018 - 16:17 CEST
Investigating
Company profiles present high load times in Trustpilot.com
Posted 4 months ago. Aug 13, 2018 - 16:02 CEST
This incident affected: General Availability (www.trustpilot.com).