Elevated API Errors
Incident Report for Trustpilot
Resolved
This incident has been resolved.
Posted almost 2 years ago. Nov 22, 2017 - 16:20 CET
Investigating
We're experiencing an elevated level of API errors and are currently looking into the issue.
Posted almost 2 years ago. Nov 22, 2017 - 16:03 CET