Degraded Performance on trustpilot.com
Incident Report for Trustpilot
Resolved
This incident has been resolved.
Posted Jul 01, 2020 - 22:30 CEST
Update
The issue is now resolved
Posted Jul 01, 2020 - 22:26 CEST
Investigating
We're experiencing an elevated level of errors on trustpilot.com.
Currently, users are not able to accept terms, change their password and delete their account when signed up with Facebook or Google.
Posted Jul 01, 2020 - 22:21 CEST
This incident affected: General Availability (www.trustpilot.com).