Partial outage on business.trustpilot.com
Incident Report for Trustpilot
Resolved
This incident has been resolved.
Posted Jun 08, 2021 - 14:01 CEST
Monitoring
We are monitoring the system as a 3rd party network provider identified the issue and implemented a fix.
Posted Jun 08, 2021 - 13:01 CEST
Update
We are continuing to investigate this issue.
Posted Jun 08, 2021 - 12:50 CEST
Investigating
We are aware of intermittent issues affecting availability of our business site. This is related to an ongoing outage with a 3rd party network provider. We thank you for your patience, and we'll continue to do what we can to mitigate this issue as much as possible.
Posted Jun 08, 2021 - 12:26 CEST