Delay on invitations
Incident Report for Trustpilot
Resolved
This incident has been resolved.
Posted about 1 month ago. Dec 20, 2018 - 19:29 CET
Monitoring
We've identified the bottleneck and the queue are being processed faster now. There will still be delays for some hours
Posted about 1 month ago. Dec 20, 2018 - 14:50 CET
Investigating
We're a experiencing a queue of invitations bigger than usual. All of them is being processed, but expect some delays
Posted about 1 month ago. Dec 20, 2018 - 13:12 CET