Business App | Delayed Service Reviews and Replies
Incident Report for Trustpilot
Resolved
This incident has been resolved.
Posted May 24, 2022 - 13:44 CEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 24, 2022 - 12:53 CEST
Update
We are continuing to investigate, and will provide a further update by 11:00 UTC
Posted May 24, 2022 - 12:29 CEST
Update
We are continuing to investigate, and will provide a further update by 10:30 UTC
Posted May 24, 2022 - 11:59 CEST
Update
We are continuing to investigate the cause of the problem. We'll provide an update by 10:00 UTC.
Posted May 24, 2022 - 11:29 CEST
Investigating
All users of the service reviews page in our Business application are currently affected by processing delays on review creation and review management. This includes replies and tag changes. We apologize for the inconvenience and will update as soon as delays are resolved.
Posted May 24, 2022 - 11:12 CEST
This incident affected: General Availability (Business Portal) and Other websites (business.trustpilot.com).