Errors loading some pages in Trustpilot.com
Incident Report for Trustpilot
Resolved
This incident has been resolved. Users of trustpilot.com may have experienced slow page loads and/or errors loading some content.
Posted Sep 05, 2020 - 16:06 CEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 05, 2020 - 15:20 CEST
Identified
We are investigating issues loading some pages in trustpilot.com
Posted Sep 05, 2020 - 14:41 CEST
This incident affected: General Availability (www.trustpilot.com).