B2B Application Sign-In
Incident Report for Trustpilot
Resolved
This incident is now resolved.
Posted Oct 19, 2023 - 17:12 CEST
Monitoring
We've deployed a fix, and we're actively monitoring the situation. We expect this issue to be fully resolved in the next 30 minutes. Thanks for your patience.
Posted Oct 19, 2023 - 17:08 CEST
Identified
We are aware of an issue preventing users from signing in to our B2B application. We're actively working on resolving the issue. Further updates will be provided at 15:30 UTC.
Posted Oct 19, 2023 - 16:53 CEST