Email widgets are currently not loading all their content properly

Incident Report for Trustpilot

Resolved

This incident has been resolved.
Posted Sep 26, 2023 - 16:03 CEST

Update

We are continuing to monitor for any further issues.
Posted Sep 26, 2023 - 10:48 CEST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 25, 2023 - 15:56 CEST

Investigating

This is affecting all email widgets apart from Newsletter 3
Posted Sep 25, 2023 - 15:09 CEST
This incident affected: General Availability (TrustBoxes).