Integration Product Catalog Update Delays

Incident Report for Trustpilot

Update

We continue to monitor the situation, and all signs look good. We're working on reprocessing any delayed webhook events and anticipate completing this data reconciliation by early afternoon, ~13:00 UTC.
Posted Apr 04, 2025 - 10:56 CEST

Monitoring

A fix has been deployed. We'll begin to cautiously reprocess delayed product updates whilst continuing to monitor the situation.
Posted Apr 03, 2025 - 15:51 CEST

Identified

We believe we have identified a contributing factor to this incident and are testing a potential fix. Some customers may continue to see stale product information and we plan to reprocess product updates once we have confidence that a fix has been found.
Posted Apr 03, 2025 - 15:16 CEST

Update

We continue to investigate this issue and will provide further updates when they become available.
Posted Apr 03, 2025 - 13:55 CEST

Update

We continue to investigate this issue and will provide further updates when they become available.
Posted Apr 03, 2025 - 11:54 CEST

Investigating

We are aware of an issue affecting the recency of product catalogs for some of our integrations, including but not limited to: Wix and Shopify. This means that updates made by customers using our integrations may not yet be reflected in the product catalogs hosted on our platform. We're actively investigating this issue, and will provide further updates as new information becomes available. No action is required on the part of our integrations customers, and product catalog updates will be reprocessed once this issue has been resolved.
Posted Apr 03, 2025 - 10:36 CEST