Invitation history not loading correctly

Incident Report for Trustpilot

Resolved

All systems continue to operate as expected.
Posted Jun 18, 2025 - 11:20 CEST

Monitoring

We’ve identified the cause of the issue and made changes to mitigate. We continue to monitor the situation.
Posted Jun 17, 2025 - 15:39 CEST

Investigating

Invitation history is not loading correctly for some users and invitation changes are slow to update.
Posted Jun 17, 2025 - 14:33 CEST
This incident affected: General Availability (APIs, Business Portal).