Delays sending invitations
Incident Report for Trustpilot
Resolved
All queued invitations have been processed.
Posted Sep 19, 2020 - 08:17 CEST
Identified
We are processing a long backlog of invitations.
All invitations are queued properly, but customers may observe a delay in email delivery.
Posted Sep 18, 2020 - 15:44 CEST
This incident affected: General Availability (APIs, www.trustpilot.com, Business Portal, TrustBoxes).