We’re currently experiencing an issue with writing product reviews on trustpilot.com
Incident Report for Trustpilot
Resolved
This incident has been resolved.
Posted Nov 20, 2023 - 17:35 CET
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 20, 2023 - 17:03 CET
Identified
The issue has been identified and a fix is being implemented.
Posted Nov 20, 2023 - 16:56 CET
Investigating
Some users are having trouble writing and submitting product reviews right now. Trustpilot is aware of the issue and working to resolve it urgently. We apologize for any inconvenience.
Posted Nov 20, 2023 - 16:30 CET
This incident affected: General Availability (www.trustpilot.com).