We are continuing to monitor for any further issues.
Posted Mar 27, 2025 - 14:33 CET
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 27, 2025 - 14:29 CET
Update
Users may be experiencing a partial outage with Zapier integration invitations. The Trustpilot team has identified the issue and is currently working on a permanent solution.
In the meantime, if you need to send invitations via Zapier urgently, we recommend re-authenticating the Zapier integration.
We apologize for any inconvenience this may cause.
Posted Mar 27, 2025 - 12:41 CET
Identified
Some users are having difficulty with re-authenticating with our integration on Zapier at the moment, no invitations are being sent. Trustpilot is aware of the issue and working to resolve it urgently. We apologize for any inconvenience.
Posted Mar 27, 2025 - 12:12 CET
This incident affected: General Availability (APIs) and invitation-reviews (default-template, custom template).