Delays Sending Review Invitations Emails
Incident Report for Trustpilot
Resolved
We're happy to share that the backlog of review invitation emails has been cleared. Thank you for your patience and understanding.
Posted Oct 10, 2024 - 23:05 CEST
Monitoring
We have identified and resolve the issue causing delays to review invitation emails being delivered. We estimate that the backlog of pending review invitation emails should be cleared in ~2-3 hours. We'll provide a further update by 21:00 UTC.
Posted Oct 10, 2024 - 20:48 CEST
Update
We continue to investigate the root cause of these email invitation delays, and we thank for your patience. We'll provide a further update by 19:00 UTC.
Posted Oct 10, 2024 - 18:20 CEST
Update
We continue to investigate the root cause of these email invitation delays, and we will provide a further update by 16:00 UTC.
Posted Oct 10, 2024 - 16:58 CEST
Update
We continue to investigate the root cause of these email invitation delays, and we thank for your patience. We'll provide a further update by 15:00 UTC.
Posted Oct 10, 2024 - 15:56 CEST
Investigating
We're aware of an issue delaying the sending of review invitations emails and custom template emails. We're currently investigating and aim to provide a further update by 14:00 UTC.
Posted Oct 10, 2024 - 15:13 CEST
This incident affected: invitation-reviews (default-template, custom template).