Review Invitation Email Delay
Incident Report for Trustpilot
Resolved
We're happy to confirm that the backlog of delayed review invitation emails has been cleared. Thanks for your patience.
Posted Jul 19, 2024 - 21:33 CEST
Monitoring
We are actively processing through the queue of delayed review invitation emails, and will continue to monitor progress.
Posted Jul 19, 2024 - 21:09 CEST
Update
We are continuing to work on a fix for this issue.
Posted Jul 19, 2024 - 21:08 CEST
Identified
We are aware of a delay in sending review invitation emails, effective from 17:26 BST. As of 19:02 BST review invitation emails are being successfully sent. This represents a period of ~90 minutes in which review invitation emails have been queued. We are actively working to process this backlog, and hope to have these emails delivered as soon as possible. Thanks for your patience.
Posted Jul 19, 2024 - 20:14 CEST