Elevated API Errors
Incident Report for Trustpilot
Resolved
This incident has been resolved.
Posted almost 2 years ago. Oct 04, 2017 - 08:34 CEST
Investigating
We're experiencing an elevated level of API errors and are currently looking into the issue.
Posted almost 2 years ago. Oct 04, 2017 - 07:57 CEST