Product Review widgets with review sharing not working as expected

Incident Report for Trustpilot

Identified

An upgrade to one our databases has not gone as smoothly as expected.
We are currently working on getting it back and running properly.
Posted Sep 16, 2026 - 15:01 CEST

Investigating

Customers using Product Review widgets with review sharing may not be showing reviews as expected.
Posted Sep 16, 2026 - 14:46 CEST
This incident affects: General Availability (TrustBoxes).