We are currently experiencing issues with creating reviews from invitations.
Incident Report for Trustpilot
Resolved
This incident has been resolved.
Posted Jun 03, 2021 - 11:46 CEST
Investigating
We're experiencing an elevated level of errors on trustpilot.com and are currently looking into the issue.
Posted Jun 03, 2021 - 11:30 CEST
This incident affected: General Availability (www.trustpilot.com).