Data replication issues in our backend

Incident Report for Trustpilot

Resolved

The fix has now been confirmed.
Posted Mar 11, 2025 - 14:57 CET

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 11, 2025 - 14:18 CET

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 11, 2025 - 13:54 CET

Investigating

At the moment we're experience data replication issues in our backend. We're currently working on this issue. We're sorry for any inconveniences.
Posted Mar 11, 2025 - 13:51 CET
This incident affected: General Availability (www.trustpilot.com, Business Portal).