Degraded site performance
Incident Report for Trustpilot
Resolved
This incident has been resolved.
Posted 3 months ago. Sep 25, 2018 - 11:39 CEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 3 months ago. Sep 25, 2018 - 11:37 CEST
Identified
The issue has been identified and a fix is being implemented.
Posted 3 months ago. Sep 25, 2018 - 11:20 CEST
Update
b2b.trustpilot.com is impacted too. Investigating.
Posted 3 months ago. Sep 25, 2018 - 10:56 CEST
Investigating
We're experiencing an elevated level of website errors and are currently looking into the issue. Mostly affecting company profile pages.
Posted 3 months ago. Sep 25, 2018 - 10:51 CEST
This incident affected: General Availability (www.trustpilot.com, Business Portal).