We are currently experiencing issues with sending out webhooks
Incident Report for Trustpilot
Resolved
We've identified the issue and remediated it. We will recover lost events and update the webhooks retroactively in the following days.
Posted Oct 07, 2021 - 20:55 CEST
Identified
Customers that have signed up for our webhooks product with APIs that are using ISRG Root X1 certificate are not receiving any events from us. Trustpilot is aware of the issue and working to resolve it. We apologize for any inconvenience.
Posted Oct 07, 2021 - 11:20 CEST