We are currently experiencing issues with processing reviews on trustpilot.com
Incident Report for Trustpilot
Resolved
This incident has been resolved.
Posted Jun 21, 2021 - 18:38 CEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 21, 2021 - 18:02 CEST
Identified
We are currently experiencing issues with processing reviews on trustpilot.com
Posted Jun 21, 2021 - 17:27 CEST
This incident affected: General Availability (APIs, www.trustpilot.com).