Degraded performance on trustpilot.com
Incident Report for Trustpilot
Resolved
All systems are operating normally.
Posted 10 months ago. Feb 12, 2018 - 16:00 CET
Update
We are still keeping an eye on this, as we are not completely satisfied we've addressed the root issue yet.
Posted 10 months ago. Feb 12, 2018 - 14:53 CET
Monitoring
The problem has now been fixed, where we identified a long running query on the databases which caused further delays on our API's affecting services such as search, login, get latest review, to list a few of them of impact.
We will continue to monitor this problem until we deem the issue to be properly resolved.
Posted 10 months ago. Feb 12, 2018 - 11:45 CET
Identified
The issue has been identified and a fix is being implemented.
Posted 10 months ago. Feb 12, 2018 - 11:35 CET
Investigating
We're experiencing an elevated level of errors and are currently looking into the issue.
Posted 10 months ago. Feb 12, 2018 - 11:23 CET