Degraded service on businessunitproducts-api

Incident Report for Trustpilot

Resolved

This incident has been resolved.
Posted Mar 25, 2026 - 00:43 CET

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 24, 2026 - 23:36 CET

Update

We are continuing to investigate this issue. The product catalog and related areas of the B2B app are currently impacted, along with potential impact on some widgets.
Posted Mar 24, 2026 - 22:46 CET

Investigating

We are currently investigating this issue which may be impacting some users in accessing their business product catalog.
Posted Mar 24, 2026 - 22:18 CET
This incident affected: General Availability (Business Portal).