Delays sending business notifications emails
Incident Report for Trustpilot
Resolved
The email backlog has been cleared, and business email delivery has returned to normal operations.
Posted Oct 10, 2024 - 11:38 CEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 10, 2024 - 09:59 CEST
Identified
The issue has been identified and a fix is being implemented.
Posted Oct 09, 2024 - 15:30 CEST
Investigating
We are currently investigating a service disruption with the sending of business-related emails.
Posted Oct 09, 2024 - 12:15 CEST
This incident affected: emails.