We are currently experiencing issues with part our business site
Incident Report for Trustpilot
Resolved
We have confirmed that all pages previously affected are now considered resolved.
Posted Aug 24, 2023 - 14:00 CEST
Monitoring
Our third party have confirmed that they have rolled out a fix and we are seeing the pages which were not loading or rendering properly across markets on business.trustpilot.com and legal.trustpilot.com returning to normal as suspected. We will continue to monitor throughout the day.
Posted Aug 24, 2023 - 10:42 CEST
Update
We are continuing to work on a fix for this issue.
Posted Aug 24, 2023 - 10:40 CEST
Update
The issues we are experiencing where certain pages are not loading or rendering properly across markets on business.trustpilot.com and legal.trustpilot.com is ongoing, we have identified an issue with resolving certain data from our 3rd party. The 3rd party are actively investigating on their end and as soon as they have implemented a fix we hope services should return to normal on our end.
Posted Aug 23, 2023 - 21:20 CEST
Identified
We have identified an issue with a 3rd party provider resulting in some pages not resolving data causing them to be unreachable, once we get confirmation that they have implemented a fix we will provide further updates.
Posted Aug 23, 2023 - 11:42 CEST
Investigating
We are currently investigating issues regarding booking a demo and the free sign-up pages, we will update once we know more.
Posted Aug 23, 2023 - 10:18 CEST
This incident affected: Other websites (business.trustpilot.com, legal.trustpilot.com).