Service Outage: Business App

Incident Report for Trustpilot

Resolved

This incident has been resolved.
Posted May 16, 2025 - 14:23 CEST

Monitoring

Some users are having trouble accessing our business app at the moment. Trustpilot is aware of the issue and working to resolve it urgently. We apologize for any inconvenience.
Posted May 16, 2025 - 14:03 CEST
This incident affected: General Availability (APIs, Business Portal).