Delay when sending invitations and emails

Incident Report for Trustpilot

Resolved

This incident has been resolved.
Posted Jan 12, 2020 - 01:15 CET

Monitoring

System is on its way back to normal.
Posted Jan 10, 2020 - 16:15 CET

Identified

We are experiencing a delay when sending out emails and invitations.
Posted Jan 10, 2020 - 15:48 CET