Review publication delay
Incident Report for Trustpilot
Resolved
This incident has been resolved.
Posted Mar 14, 2022 - 20:35 CET
Monitoring
Delays in service reviews should be resolved.
Posted Mar 14, 2022 - 18:59 CET
Update
We are continuing to investigate this issue.
Posted Mar 14, 2022 - 14:55 CET
Investigating
Users are currently experiencing delays in service reviews, where new reviews and updates like replies and tag modifications are delayed after submission in the Service Reviews page in the business portal. Delays can be up to 15 minutes. The page is still interactive and actions can be submitted without problem.

Reviews are similarly delayed from showing on www.trustpilot.com.

We apologize for the inconvenience.
Posted Mar 14, 2022 - 13:41 CET
This incident affected: General Availability (www.trustpilot.com, Business Portal).