Delay in showing new reviews and replies in the business app
Incident Report for Trustpilot
Resolved
This incident has been resolved.
Posted Apr 12, 2022 - 16:50 CEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 12, 2022 - 16:02 CEST
Identified
All users of the service reviews page in our Business application are currently affected by processing delays on review creation and review management. This includes replies and tag changes. We apologize for the inconvenience and will update as soon as delays are resolved.
Posted Apr 12, 2022 - 15:34 CEST
This incident affected: General Availability (Business Portal).