B2B Review Inbox Not Loading
Incident Report for Trustpilot
Resolved
Thank you for being so patient. We're happy to confirm that the incident affecting the invitation inbox of our B2B customers has been resolved.
Posted Oct 19, 2023 - 19:41 CEST
Monitoring
We've identified the issue, and regular service should be restored soon. We'll continue to monitor the situation and provide a further update no later than 18:00 UTC
Posted Oct 19, 2023 - 19:25 CEST
Update
Thanks for your patience. We're continuing to investigate this problem.
Posted Oct 19, 2023 - 18:50 CEST
Investigating
We're aware that our B2B customers are experiencing issues accessing their review inbox, and we're actively investigating. We'll provide further updates no later than 18:00 UTC.
Posted Oct 19, 2023 - 18:27 CEST