Elevated error rate
Incident Report for Trustpilot
Resolved
This incident has been resolved.
Posted 4 months ago. May 07, 2019 - 16:10 CEST
Update
Issue has been resolved
Posted 4 months ago. May 07, 2019 - 16:09 CEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 4 months ago. May 07, 2019 - 15:39 CEST
Update
We are continuing to work on a fix for this issue.
Posted 4 months ago. May 07, 2019 - 15:39 CEST
Identified
The issue has been identified and a fix is being implemented.
Posted 4 months ago. May 07, 2019 - 15:09 CEST
Investigating
Some users are experiencing issues loading company profile pages and reviews. The issue might be local to Australia and New Zealand. Investigation is ongoing.
Posted 4 months ago. May 07, 2019 - 14:36 CEST
This incident affected: General Availability (www.trustpilot.com).