Service Outage: Business App
Incident Report for Trustpilot
Resolved
This incident has been resolved.
Posted Mar 16, 2023 - 11:12 CET
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 16, 2023 - 10:41 CET
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 16, 2023 - 10:35 CET
Investigating
Some users are having trouble replying to reviews.
Trustpilot is aware of the issue and working to resolve it urgently. We apologize for any inconvenience.
Posted Mar 16, 2023 - 10:20 CET