Service Degraded To Some Business Features
Incident Report for Trustpilot
Resolved
This incident has been resolved.
Posted Nov 25, 2022 - 13:24 CET
Investigating
We are aware of some service degradation to some of our business features. There should be no impact on our main trustpilot.com site.
Posted Nov 25, 2022 - 11:17 CET
This incident affected: General Availability (Business Portal) and Other websites (business.trustpilot.com).