We are currently experiencing issues with processing data throughout or services
Incident Report for Trustpilot
Resolved
This incident has been resolved.
Posted Sep 22, 2022 - 11:46 CEST
Update
We are continuing to work on a fix for this issue.
Posted Sep 22, 2022 - 11:45 CEST
Identified
We are currently experiencing issues with processing data throughout a number of our services, which might cause certain information to be outdated. Trustpilot is aware of the issue and working to resolve it urgently. We apologize for any inconvenience.
Posted Sep 22, 2022 - 11:05 CEST
This incident affected: General Availability (www.trustpilot.com).