Degraded Trustpilot.com site performance
Incident Report for Trustpilot
Resolved
The fix has resolved the immediate problem, and service has returned to stable. Will continue to monitor closely.
Posted over 1 year ago. May 16, 2017 - 14:08 CEST
Update
Root cause identified, and a fix is being deployed right now to resolve.
Posted over 1 year ago. May 16, 2017 - 14:03 CEST
Identified
We've identified a performance issue on our backend, and addressing with urgency. Affecting www.trustpilot.com & search functionality ATM.
Posted over 1 year ago. May 16, 2017 - 13:37 CEST