Authentication errors
Incident Report for Trustpilot
Resolved
This incident has been resolved.
Posted about 1 year ago. Nov 17, 2017 - 10:28 CET
Identified
Authentications errors are now only effecting Facebook logins
Posted about 1 year ago. Nov 17, 2017 - 09:11 CET
Investigating
We're experiencing an elevated level of errors on authentication
Posted about 1 year ago. Nov 17, 2017 - 07:56 CET