B2B App Not Loading
Incident Report for Trustpilot
Resolved
This incident has been resolved.
Posted Oct 03, 2022 - 16:25 CEST
Monitoring
We'll continue to monitor the fix over the weekend.
Posted Sep 30, 2022 - 17:59 CEST
Identified
We've identified the issue and a fix has been put in place.
Posted Sep 30, 2022 - 17:59 CEST
Investigating
We're investigating reports of some users encountering a blank screen when they sign in to our B2B application,
Posted Sep 29, 2022 - 17:44 CEST