New review - processing delays
Incident Report for Trustpilot
Resolved
This incident has been resolved.
Posted over 1 year ago. Jun 06, 2017 - 10:38 CEST
Monitoring
We are experiencing minor delays in review processing, which is delaying the new review from being displayed.
The issue has been identified, and the backlog queue is being processed with additional scale.
No reviews have been lost and the system should be caught up shortly.
Posted over 1 year ago. Jun 06, 2017 - 10:13 CEST